Donate to Remove ads

Got a credit card? use our Credit Card & Finance Calculators

Thanks to OLTB,Cornytiv34,Blatter,eyeball08,ADrunkenMarcus, for Donating to support the site

Issue with lastprice

Discussions regarding financial software
StepOne
Lemon Slice
Posts: 609
Joined: November 4th, 2016, 9:17 am
Has thanked: 181 times
Been thanked: 159 times

Issue with lastprice

#252526

Postby StepOne » September 18th, 2019, 1:09 pm

Hi All,

Since the issues early last week with getting prices from Yahoo using the TLF addin (written by eventide I think) I have been having strange problems with one of my portfolio spreadsheets. (I don't know if the timing is a coincidence)

Before last week, whenever I opened my spreadsheet, the prices would be populated. Right-clicking and selecting 'TLF Update' and would update the prices. This was the same on 2 spreadsheets I run for 2 portfolios (call them A and B).

Since last week's issues, though, when I open spreadsheet A, all the prices say ':queued:', and running 'TLF update' has no effect. I have discovered a workaround is that I can go into each of the cells, press F2 and Enter (so effectively editing the cell although making no changes), and then refresh and the prices will update. If I press 'F2' on some of the cells, but not others, then the prices will only update in the cells which have been edited - the rest remain saying :queued:.

Spreadsheet B, for a different portfolio, still works the original way - prices update first time with no need to edit the cells. I have compared the code in each spreadsheet and they are visually identical.

After last weeks issues, I did update a line of code in both spreadsheets, per eventide's instructions. It was to change an error check from checking .StatusText, to using .Status. I made the same change in both my spreadsheets.

I tried creating a new spreadsheet, copying my data into it, and importing the code from spreadsheet A, and it suffers exactly the same issue. So I create a second new spreadsheet, and this time copied the code in from spreadsheet B, and it still has the same issue. It seems that even starting afresh with a new spreadsheet is not working.

I'm curious whether anyone else uses the TLF add-in and 'getdata' function, and if they have the same problem - it would be good to know what shows in the spreadsheet cells when they first open the spreadsheet - the last value, or 'queued'. And does anyone have any suggestions on how to resolve this?

Thanks
StepOne

Return to “Financial Software - Discussion”

Who is online

Users browsing this forum: No registered users and 7 guests